Samsung Washing machine not draining/responding


Samsung Washing machine not draining/responding

Author
Message
Steven Renner
View Quick Profile

Forum Guru
Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 7, Visits: 27
Hello!
Thank you for taking the time to review my question.  I'm attempting to repair a Samsung washing machine, model number WF337aag/xaa.  Client asked me to check it as it is not draining.  I investigated, found most functions intact, but the machine was not draining.  I checked all the usual items, and decided the drain pump was fried.  Replaced the drain pump, and now the machine is still not draining and the drain pump does not respond in the self test mode.  Might I need to change out the control board?

Thank you!

Steven
Admin
View Quick Profile

Supreme Being
Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)

Group: Administrators
Last Active: Yesterday @ 10:52 PM
Posts: 2.3K, Visits: 15.1K
Sorry to hear of this issue. This is most likely a control board issue.
The control board for this washer is no longer available. Perhaps you can locate a rebuilt one somewhere online.





Steven Renner
View Quick Profile

Forum Guru
Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)Forum Guru (830 reputation)

Group: Forum Members
Last Active: 3 Months Ago
Posts: 7, Visits: 27
Hello!
I was able to find a board, installed it, but the machine is not responding correctly.  In test mode it fills and agitates, but does not drain and now the door stays locked.  Is there a way to reset the machine?  I followed the procedure to clear fault codes but it does nto seem to have made a difference.
Admin
View Quick Profile

Supreme Being
Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)

Group: Administrators
Last Active: Yesterday @ 10:52 PM
Posts: 2.3K, Visits: 15.1K
Hello,
The original problem you described indeed points to a faulty control board. Since this control board is no longer produced, I assume you got a used one which could again "be faulty as well"  You could have another issue but you already replaced the pump and these symptoms still sound like a control board issue. Unless you find a brand new one of these which is probably difficult since they have not been made in at least 3 years I would say you are still looking at the same problem. Hopefully you can send back the one you purchased.





Admin
View Quick Profile

Supreme Being
Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)Supreme Being (307.5K reputation)

Group: Administrators
Last Active: Yesterday @ 10:52 PM
Posts: 2.3K, Visits: 15.1K
Have you checked the door lock? interesting that it is staying locked .. the pump will not operate unless the door lock is locked but now that it is staying locked it should start to drain which takes me back to the original issue which is the control board. I was just curious if you checked the lock to make sure it was locking and unlocking 





Reading This Topic