Whirlpool Oven Dead After Self Cleaning


Whirlpool Oven Dead After Self Cleaning

Author
Message
mattstone87
View Quick Profile

Junior Member
Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)Junior Member (244 reputation)

Group: Awaiting Activation
Last Active: 10 Months Ago
Posts: 1, Visits: 11
I have replaced the broken thermistor and thermal fuse.  The control panel has also been replaced.  What is the next thing I can check?  Whirlpool Model WOS51ES4EW00 Thank you for any help you can provide.
Admin
View Quick Profile

Supreme Being
Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)

Group: Administrators
Last Active: 1 hour ago
Posts: 2.3K, Visits: 13.1K
This should be the part you replaced? https://www.searspartsdirect.com/product/3q6g845drr-0022-664/id-w10721213





Admin
View Quick Profile

Supreme Being
Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)Supreme Being (165.2K reputation)

Group: Administrators
Last Active: 1 hour ago
Posts: 2.3K, Visits: 13.1K
Also we have had these issues happen before after using self clean so try searching this within the forum as you will find several similar posts with answers to how the issue was resolved







Reading This Topic