GE GSS20IEPDWW wierd derfrost issue


GE GSS20IEPDWW wierd derfrost issue

Author
Message
imaddicted2u
View Quick Profile

Supreme Being
Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 12, Visits: 111
Recently I noticed something odd with the defrost cycle. It may have always done it and wasn't noticed.
The defrost cycle works perfectly two times. The third time it messes up and the pattern repeats.
The adaptive defrost cycle is supposed to go like this. The time between defrost cycles is determined through calculation in the computer controller and based on the number and length of time the doors are open. When a defrost is triggered, the compressor runs for 2 hours to pre-chill the freezer section then it turns off, the defrost heater is turned on, the condenser and evaporator fans are turned off. The temperature at the top of the evaporator is monitored by a thermistor. When the temperature reaches around 20-25 degrees F, the heater is turned off and 5 minutes is allowed to pass, to allow remaining water to drip away, before the compressor and condenser fan are started. To allow the evap coil to cool back down the controller waits 10 minutes before starting up the evaporator fan. When a normal cycle ends the freezer temp is around 0 degrees F.
The problem is, every third cycle the compressor and condenser fan shut off but the evap fan keeps on going. As a consequence of the evap fan running the freezer section temperature rises to about 20 degrees F and the items in the freezer get covered in frost due to the abnormal air circulation. The fan being on causes the defrost heater to stay on for about 40 minutes which happens to be the max time the controller will allow the heater to stay on. On successful cycles the defrost heater is on for 13-15 minutes.
Since it's consistently every third cycle that messes up it's hard to imagine that any components have failed except possibly the program or the controller. Since everything else is working and the evap fan is supposed to be off anyway, I'm going to try adding in a relay with 120 volt coil to remove the power to the evap fan when the defrost heater is turned on by the controller.
Worth a shot Smile


; height: 22px; width: 22px; top: 10px; left: 10px;" class="simple-translate-button ">

Attachments
GE GSS201EPD schematic.jpg (118 views, 603.00 KB)
Admin
View Quick Profile

Supreme Being
Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)Supreme Being (327.1K reputation)

Group: Administrators
Last Active: 2 days ago @ 5:38 PM
Posts: 2.4K, Visits: 15.3K
Hello,

My guess is this board is the issue but the symptoms you describe are not typical of the board issue but still my guess on it  https://www.speedyapplianceparts.com/ge-wr55x10942p-refrigerator-main-control-board-replacement/





imaddicted2u
View Quick Profile

Supreme Being
Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)Supreme Being (1.3K reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 12, Visits: 111
Admin - 8/15/2019 2:34:26 PM
Hello,

My guess is this board is the issue but the symptoms you describe are not typical of the board issue but still my guess on it  https://www.speedyapplianceparts.com/ge-wr55x10942p-refrigerator-main-control-board-replacement/


Thanks, 8 perfect defrost cycles later...right way or wrong way, adding the relay fixed the defrost issue, I believe it's a board issue also but the fridge has never worked so good so I wouldn't consider changing it.
; height: 22px; width: 22px; top: 10px; left: 10px;" class="simple-translate-button ">

Edited
2 Years Ago by imaddicted2u


Reading This Topic