Frigidaire Electric Range Dual Radiant Burner Outer Ring not working


Frigidaire Electric Range Dual Radiant Burner Outer Ring not working

Author
Message
geoffdude
View Quick Profile

Forum Guru
Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 9, Visits: 114
Hello,

My first post, request for assistance.

I have a Frigidaire Gallery Professional Series - Convection / Electric Range (1999-2000 time-frame)
Model # FEF389WFCF

The front left-side dual radiant burner is not working properly. The outer heat element ring never turns on. The inside main element comes on no problem, it's just the outer ring that just won't work. - The right-side version of this surface element works perfectly.

I've replaced the Dual Element Rocker Switch and the Surface Element Control Switch but the problem persist. I've taken the left burner and placed it on the right side and it works fine. I placed the right burner on the left side and the problem affects that burner too, so it's not the burners.

Any other ideas on what the problem may be?

At this point I'm lost .. only thing I can think of is it may be the control board? That sound right?

If it's the Control Board then what does that entail? Eeesh.

====== BELOW: Parts I've Been Replacing/Testing =======

- Frigidaire Oven Range Stove Surface Burner Element #316049702 (works when transposed with right one)
- Dual Element Rocker Switch #316083100 (replaced with new one, tested for continuity it was fine)
- Surface element control switch, dual burner #316049800 (replaced with new/used one, continuity fine)

http://i66.tinypic.com/9iwh0j.jpg
 
http://i63.tinypic.com/rbbkat.jpg

http://i68.tinypic.com/2hn9m38.jpg


Edited
3 Years Ago by geoffdude
Admin
View Quick Profile

Supreme Being
Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 2.3K, Visits: 14.8K
Hello,
Thank you for posting. This one took a little bit of research. #1 my question is on the burner control switch, did you install a used one?
#2 I think this is the burner switch for the larger elements, the part # you show you replaced seems to be a more on/off switch that is not thermostatically controlled. like this one is https://www.appliancezone.com/316436000-frigidaire-range-surface-element-switch/





geoffdude
View Quick Profile

Forum Guru
Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 9, Visits: 114
Thanks for the reply.

The part was used, but I did test it before I placed it in. It checked out/worked .. at least for continuity.

Here's the part new: https://www.appliancezone.com/316049800-frigidaire-range-surface-element-switch/

Here's the right part number (#316049800) and some pics below.

http://i63.tinypic.com/2v9aikl.jpg

http://i64.tinypic.com/103hi85.jpg

http://i65.tinypic.com/2aaeu6w.jpg


Edited
3 Years Ago by geoffdude
Admin
View Quick Profile

Supreme Being
Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 2.3K, Visits: 14.8K
thank you for the additional info. So there isnt anything else but the rocker switch, the burner switch and the element.. those are the only three things that could possibly cause this kind of issue. Do we know the burner element you received was brand new? It has power going to it but if the outer ring is not getting hot something isnt adding up. I have seen many of these elements get returned to dealers that could of been previously installed but end up right back on the shelf for the next customer to receive.





geoffdude
View Quick Profile

Forum Guru
Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 9, Visits: 114
I didn't buy a new burner element, as I transposed it to the right side and both rings worked.

I then placed the right side burner element on the left side and the problem continued even with the burners swapped.

The burner element switch I purchased was used and not new. I tested it following a video on youtube that showed the proper testing configurations (H1, H2 to P, etc.) and it seemed/seems like it was OK.

The rocker switch was new.









Admin
View Quick Profile

Supreme Being
Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 2.3K, Visits: 14.8K
That's right, I am sorry I had to go back and read your original description. Sometimes I get mixed up when answering a lot of questions in a short time frame.
So back to your issue. Something is a little puzzling here looking at the tech sheets. Your front left burner is part #316049706 which is different from all the other burners, yet the burner switch shown in illustration is 54c not 54.. I do not see the part# for 54c but I do for 54 which is 316436000... Also, in the schematic this part #316083100 Dual element switch looks to be part of the electrical circuit.. I dont know exactly what that switch does because I can't see the entire schematics for this range... have you tested the dual element switch, is this something you use often?






geoffdude
View Quick Profile

Forum Guru
Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 9, Visits: 114
No worries .. thx again for all the help. (Merry Xmas too) Smile

Here's the isolated schematics area, with my color enhancements, for that section of the range.

The purple areas are segments/parts I've not done anything to.. not sure what LR LMT SW and LF LWT SW are (smaller purple border areas). The other larger purple area is the left side switch for the left rear surface element (diagram #54 / OEM part #316436000) which I also did not replace/test.             

The green areas are the dual switch I replaced and the rocker switch I replaced .. I didn't replace the oven lamp switch but it's border green too as it's part of the left front circuit.

Large Green border area = part number #316049800 (only one I replaced/tested)
Large Purple border area = part number #316436000

http://i64.tinypic.com/2cptjir.jpg


Admin
View Quick Profile

Supreme Being
Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 2.3K, Visits: 14.8K
Hello,

After studying this I go back to the burner switch... this is the switch that is for the front left burner https://www.appliancezone.com/316436000-frigidaire-range-surface-element-switch/
I dont see anything else it could be but this switch.





Admin
View Quick Profile

Supreme Being
Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)Supreme Being (274.1K reputation)

Group: Administrators
Last Active: 13 hours ago
Posts: 2.3K, Visits: 14.8K
Also.. you have been most helpful with your detailed information, diagrams, charts.. thank you for providing so much helpful information!





geoffdude
View Quick Profile

Forum Guru
Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)Forum Guru (951 reputation)

Group: Forum Members
Last Active: 2 Years Ago
Posts: 9, Visits: 114
Thanks, the detailed images come from the Designer/Web Developer part of me.

I think the Left-Front Burner Switch you noted is actually for the Left-Back Burner only... it's about $75 dollars cheaper than the dual burner switch I would need (new) if indeed the switch is the problem.

Left-Back-Burner Switch = part number #316436000 ($34)
https://www.appliancezone.com/316436000-frigidaire-range-surface-element-switch/

Left-Front-Burner Dual Burner Switch
= part number #316049800 (The one I replaced/tested = $103)
https://www.appliancezone.com/316049800-frigidaire-range-surface-element-switch/

Is it possible any of the wiring could be bad/broken?  Would that be a somewhat probable cause?

Edited
3 Years Ago by geoffdude


Reading This Topic